A new encryption vulnerability called POODLE requires the attention of businesses that used credit card processing devices. Learn more here.
Source: Credit Card Processing
Security Alert: POODLE Vulnerability
{$excerpt:n}